憶の年

windows下安装Scrapy
直接pip install scrapy报错如下 error: Microsoft Visual C++ 14.0...
扫描右侧二维码阅读全文
08
2018/10

windows下安装Scrapy

直接pip install scrapy报错如下

 error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools": http://landinghub.visualstudio.com/visual-cpp-build-tools

QQ截图20181008192020.jpg
提示缺少Microsoft Visual C++ Build Tools其实是安装twisted模块出现问题了

解决方法
http://www.lfd.uci.edu/~gohlke/pythonlibs/#twisted 下载twisted对应版本的whl文件(如我的Twisted‑18.7.0‑cp37‑cp37m‑win_amd64.whl),cp后面是python版本,amd64代表64位

下载以后用pip安装
pip install E:\Downloads\Twisted-Twisted‑18.7.0‑cp37‑cp37m‑win_amd64.whl

注意自己文件的路径

接着继续安装Scrapy
pip install scrapy

Last modification:October 8th, 2018 at 07:28 pm

Leave a Comment